Upstream dependency conflict with latest svelte-template

Latest svelte template appears to have an “upstream dependency issue” when upgrading node. I’m not enough of an expert to know whether this has something to do with my local situation.

I was able to work through the issue using:

npm upgrade -force

PS D:\GitHub\zea-svelte-ntop> npm upgrade
npm ERR! code ERESOLVE
npm ERR! ERESOLVE unable to resolve dependency tree
npm ERR!
npm ERR! While resolving: zea-svelte-template@1.0.0
npm ERR! Found: svelte-loader@3.0.0
npm ERR! node_modules/svelte-loader
npm ERR! dev svelte-loader@"^3.0.0" from the root project
npm ERR!
npm ERR! Could not resolve dependency:
npm ERR! peer svelte-loader@"^2.9.1" from @storybook/svelte@6.1.21
npm ERR! node_modules/@storybook/svelte
npm ERR! dev @storybook/svelte@"^6.1.20" from the root project
npm ERR!
npm ERR! Fix the upstream dependency conflict, or retry
npm ERR! this command with --force, or --legacy-peer-deps
npm ERR! to accept an incorrect (and potentially broken) dependency resolution.

Hi Blake,

There seems to be an issue with that version of StoryBook on Windows that we will be investigating.
Meanwhile, inside your package.json file, can you delete all of the occurrences of storybook?

Thank you.

1 Like

Yes. That works for me. Thanks for the help.